Home Emulatori Pubblicato un primo elenco di compatibilità dei classici PS2 su PS5

[Scena PS5] Pubblicato un primo elenco di compatibilità dei classici PS2 su PS5

706
2

Il consulente e ricercatore per la sicurezza McCaulay Hudson ha condiviso il post di un utente su reddit contenente un primo elenco dei titoli PS2 compatibili che possono essere eseguiti su console PlayStation 4 e PlayStation 5 attraverso l’exploit mast1c0re.

Di solito questo tipo di elenchi possono essere trovati all’interno dellla piattaforma psdevwiki che attualmente appare piuttosto spoglia (conta appena 23 articoli) e dove non vi è ancora alcuna traccia di questo exploit.

Un elenco molto più corposo dei titoli PS2 Classics compatibili per console PlayStation 4 può essere trovato a questo indirizzo.

Per certi versi questa lista sembra più ricca grazie anche ai diversi emulatori e script in LUA che invece non sono ancora presenti nell’exploit mast1c0re.

mast1c0re

La catena di exploit mast1c0re sfrutta un bug all’interno del gioco Okage: Shadow King per console PlayStation 2 per ottenere l’esecuzione di codice all’interno dell’emulatore, tramite un exploit nel salvataggio del gioco.

Si tratta di una vulerabilità assai nota che risalirebbe addirittura al 2021, riportata dal developer e hacker Cturt sulla piattaforma HackerOne, successivamente Sony concesse la sua divulgazione senza pero correggerlo.

Sistemi supportati e versioni firmware

  • PS4:
    • 5.05.
    • 6.72.
    • 9.00.
    • 10.01.
  • PS5:
    • 6.50.

Guida

  1. Eseguire Okage Shadow King sulla console PS4 con jailbreak.
  2. Creare un personaggio e andare nella propria camera da letto nel gioco, dove sarà possibile salvare il gioco, questo creerà i tuoi dati di salvataggio iniziali.
  3. Da Apollo Save Tool, decodificare i dati di salvataggio. Questo creerà versioni decrittografate del file di salvataggio, sul disco rigido della PS4 con jailbreak.
  4. Dal PC che esegue il client FTP, connettersi alla PS4 jailbroken tramite FTP e individuare i file decrittografati. Dovrebbe esserci un file VMC0.card lì dentro. Sostituire quel file con uno degli stessi file presenti in basso (basta copiare via FTP il file sfruttato dal PC per sovrascrivere quello sulla PS4 jailbroken).
  5. Una volta eseguito l’exploit sulla console, inviare il file ELF o l’immagine ISO alla console attraverso l’utility PS2 ELF Loader o lo script Python presente in scripts/mast1c0re-send-file.py.

L’elenco di compatibilità pubblicato su Reddit può essere trovato a questo indirizzo.

Fonte: wololo.net

2 Commenti

  1. ciao ma che convenienza ho a usare questo exploit piuttosto che creare un fpkg del gioco ps2? le compatibilitá sono le stesse o con il nuovo exploit ci sono piú giochi compatibili?

    • Attualmente nessuna, il file fPKG è più conveniente in quanto sfrutta i file LUA e il file di configurazione config-emu-ps4.txt, cosa che invece attualmente non è presente in mast1c0re

      La cosa più interessante è che funziona sul più recente firmware 10.01 della PS4 e 6.50 della PS5

LASCIA UN COMMENTO

Per favore inserisci il tuo commento!
Per favore inserisci il tuo nome qui

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.