Home News La guida di Barthen non trova riscontri, attualmente impossibile eseguire giochi...

[Scena PS4] La guida di Barthen non trova riscontri, attualmente impossibile eseguire giochi recenti sul firmware 4.05 della PlayStation 4

208
5

Non ci sarebbero riscontri riguardo la guida condivisa da Barthen per l’esecuzione di giochi recenti sul firmware 4.05 della PlayStation 4 e PlayStation 4 Pro.

Allo stato attuale sarebbe possibile eseguire giochi recenti, ma solo se questi sono stati oggetto di dumping, si, serve comunque un exploit nel kernel sul firmware più recente.

Il gioco dopo essere stato dumpato può essere modificato per poter essere eseguito anche su di un firmware più basso, questo significa che chi monta ancora il firmware 1.76 potrebbe in qualche modo eseguire giochi come Final Fantasy XV o The Witcher III: Wild Hunt.

La guida nel dettaglio ci spiega come abbassare il requisito del firmware grazie alla modifica di alcuni byte che sono stati scoperti all’interno del Software Developer Kit 4.50.

Come ridurre il requisito del firmware nei file ELF e PRX

Esempio di abbassamento del firmware richiesto per i file compilati con SDK 4.50 (testato in 4.05) che modifica alcuni byte.

  • Nella sezione ELF chiamata sce_process_param applichiamo la patch alla versione SDK invertita (dovrebbe esserci solo un’istanza del pattern):
    • Cercare “01 81 50 04” e sostituirlo con “31 80 50 03”.
  • Nella sezione ELF chiamata sceversion incolliamo la versione SDK (verranno trovate più istanze del modello):
    • Cercare “04 50 81 01” e sostituirlo con “03 50 80 31”.
  • Ora compilatelo con lo strumento make_fself.py del developer flatz o aggiungetelo ad un file PKG con lo strumento Fake_PKG_Generator del developer cfwprophet.
  • Eseguire infine l’installazione del file PKG su PlayStation 4.