[Scena PS4] Cturt conferma il lavoro di un possibile kernel exploit su Playstation 4

Il developer e hacker Cturt torna con un nuovo “aggiornamento di stato” postato su Twitter, poche semplici parole che non lasciano nulla all’immaginazione: “L’exploit del kernel su PS4 finalmente funziona! Grazie a tutte le persone coinvolte!”.

PS4-System-Software-featured-image_without-number_vf1

Non si conoscono ulteriori dettagli in merito, alcuni credono che l’exploit sia già stato patchato da Sony, ma questo è normale e già lo si sapeva, d’altronde se si tratta del webkit exploit, questo può essere eseguito solo su firmware 1.76.

Sapevamo che l’hacker stava lavorando sul supporto nativo per il controller della PS4:

Il primo problema è il controller. Non sono abbastanza sicuro cosa ci sia di sbagliato, ma utilizzando il modulo libScePad.sprx questo non sembra funzionare. Forse perchè il controller è già in uso e che collegando un secondo controller questo potrebbe funzionare, ma non ho avuto modo di provare in quanto ho un solo controller.

..e che stava riscontrando problemi nell’utilizzo del modulo per la stampa a video:

Il secondo problema l’abbiamo riscontrato nel modulo libSceVideoOut.sprx, questo sembra non lavorare per noi.

Infine una limitazione non da poco nella lettura/scrittura dei dispositivi USB:

La limitazione finale è che non abbiamo i permessi per montare unità USB per poterli normalmente leggere, tuttavia abbiamo accesso al modulo libUsbd.sprx (fondamentalmente solo libusb) che ci permette di comunicare direttamente con i dispositivi USB.

Ma cosa saremo in grado di fare attraverso il kernel exploit del webkit? Semplice, una sorta di hack in stile Loadiine della console Nintendo Wii U, anche se crediamo fortemente che ci vorrà del tempo.



Source : twitter.com


6 commenti

  1. Bella iniziativa, che ingegno questo personaggio Cturt, potrebbe, dico potrebbe creare un jailbreak per avviare copie backup dei nostri videogames. Speriamo!!!!!!
    L’unica cosa che mi lascia perplesso che si posso fare prossimamente un cfw 1.76 già è una cosa, ma per quelli che hanno un OFW 3.15 aggiornato e arrivato con la release di Gennaio. Chissà come si potrà fare. Ma posso dire che ne vedremo delle belle in tutto ciò. Già ad arrivare a questo punto con questo exploit non è niente male….
    Bravo Cturt

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *